Jump to content
Sign in to follow this  
SyAlmans

Weird slowdown with September 2 update

Recommended Posts

Okay, so after three new games with no problems on generation or anything odder than seated wastrels propelling towards me like they're on invisible miniscooters the fourth new game generation had problems.

 

Basically, it took an unusually long time to load and when I could the lag was so bad I could barely move -- we're talking seconds between mouse movement and response. It was so frustrating I saved and closed the game, hoping that loading from a save would go easier. The first time I loaded it seemed to hang up on the Loot generation specifically; thinking it had frozen after 5+ minutes of no movement from the bars or change of status, I restarted. I reloaded the file and while it took around 10 minutes to complete it did, eventually, load. However, it still had the same abysmal lag. Considering I'd done three previous games without a problem I don't think it's a settings/driver thing.

 

The lag seems tied to the opening chatter from Uncle Jack, since once I finally managed to limp across the room to turn off the radio the game sped up to normal. Now that I'm out of the bunker and walking around the garden it's fine.

 

Share this post


Link to post
Share on other sites

Addendum: Same issue happening on the 5th world generation. This time the Uncle Jack audio took 30 minutes by the in-game clock to start playing at all, and it was 8:40 before I could move effectively. It also appears to be KILLING my laptop's memory as I couldn't even open Task Manager to check on memory usage.

Share this post


Link to post
Share on other sites

Hey @SyAlmans,

 

It certainly sounds like there's some sort of memory leak occurring across playthroughs. Unfortunately this kind of issue tends to show up from time to time, especially with multiple playthroughs in a single session. The broadcasts certainly sound like a lead, as we've reworked a bit how they work internally to reduce the amount of overhead from playing broadcasts.

 

Thanks for flagging it! We'll see what we can find and I'll keep you posted. In the meantime, does quitting the game to Windows and restarting help fix the issue?

Share this post


Link to post
Share on other sites

Quitting and restarting didn't help, no -- in fact, neither does shutting down and trying to reload the file at a later run date. The 4th and 5th world generations were begun on different days. I actually saved the 5th generation outside of the shelter and came back to it later, but this time coming back to the file was even worse -- when the game finally loaded the screen was completely black (with the Conformity and Quickslot icons up), and completely stalled. When I managed to open Task Manager it showed the program was entirely unresponsive, and since it took around 15-20 minutes to load that file I gave up for the day.

 

Oh, minorly, there are three pieces of scenery I notice I get "stuck" on:

 

- The flowerboxes in the City circle around the hatch

- The rubble next to the bannister in the Garden district (once so badly I had to restart)

- The see-saw (tried to get on it to reduce full aggro, was cornered, got "off" but couldn't actually move)

Share this post


Link to post
Share on other sites

Ah, I meant starting a new game after a fresh restart.

 

Although if the save game itself is bloated regardless of a restart, that's another clue as to what the issue might be. I'll see if we can reproduce it, otherwise I may ask you to send in an example save file.

Share this post


Link to post
Share on other sites

@Camille

 

I'll try another restart tonight, but I think the answer is technically yes. As far as I can recall the procedure was like this:

 

Friday: 1st, 2nd and 3rd world generations went fine. Saved 3rd generation and signed off for the night.

 

Saturday: Loaded the save file for 3rd generation, died. No problems loading the save file. Started 4th generation. Long build time and some lag initially; saved, restarted. Opened new file; long load-time, but eventually it straightened out enough for me to play normally until I got trapped on a seesaw and beaten to death.

 

Sunday: Created 5th generation. Hideous lag. Eventually managed to get outside the shelter and save. Closed game, powered down laptop for a while. Turned laptop back on and tried to open the save. Very slow to load, then froze entirely.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site you agree to the use of cookies for analytics, personalized content and ads. Privacy Policy