Jump to content
Sign in to follow this  
Jarnsaxa

Light bearer bug report

Recommended Posts

Posted (edited)

Hi, folks!

I’m playing on XBox One. I was in the kitchen of the museum, flinging gold records at my ex-wife’s insult bubbles (which is a brilliant metaphor; nice work). Throwing the gold records at any other target proved fruitless. I tried to save the game, but the save link was unavailable. I let her kill me. When I tried to go back to the main menu, but got nothing but the “happy is the country with no past” screen. The bar wasn’t loading. In frustration, I hit the Home button and shut the XBox off. Now (the XBox has used other apps in the meantime), I have the same screen. rather than the main menu or anything else. What do I do? Why can’t I completely quit the game and try again? 

Edited by Jarnsaxa

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...