Jump to content

Ps4 so foul and faraday hideout glitched

Recommended Posts

I've done the guitars on the wall and got to the point of of entering Nick's hideout however when the screen goes black I am still in the same room again I've tried an older save and I have the same issue I've done everything from getting killed by the bobbies to sleeping and travelling to different hatches and it's still the same issue goes black and I'm still in the same room and help.would be great it was a good game up until now my build no is v1.7.80097

  • Sad 1

Share this post

Link to post
Share on other sites

I’ve been having this same issue. I just sent in a support request. You should do the same, maybe they’ll be able to help. It’s frustrating because you literally can’t go any further in the game. You HAVE to find the unicorn song but it won’t let you 😒

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now