Jump to content
Sign in to follow this  
Guillaume

FAQ: I'm having trouble launching the game, what should I do? [UPDATED]

Recommended Posts

Hey everyone - here's a quick FAQ on what to do if you are having trouble running the game. I'll update it as we make changes to the game or have more info.

 

Firstly, if you're on this thread, we're sorry you're having issues.

 

1. Make sure you meet the minimum specifications for the game.

 

Operating System: Windows 7 (or higher) and a 64bit Operating System

Processor: Triple-core Intel or AMD, 2.0 GHz or faster

Memory: 6 GB RAM

Video Card: NVIDIA GeForce 460 GTX or AMD Radeon 5870 HD series or higher

Mobile: NVIDIA GeForce GTX 580M or higher.

DirectX: DirectX 11, Shader Model 4

 

If you have less than 6GB of RAM - it is likely the game will have trouble launching into the world. Those requirements may change as we optimize the game, but as of this moment, we don't support 4GB of RAM. If your operating system is not a 64bit operating system, the game will not run.

 

2. If you are running on Windows 7 or Windows 8, and the game doesn't start, it's possible you are missing critical Windows updates required for the game to run.

 

You need the universal C Runtime for Windows to run the game. It should normally get installed alongside the game, but will fail if you are behind on your windows updates.

 

To fix this, try making sure to install KB2999226 first - you can find here (make sure you install the X64 version for your operating system):

 

https://support.microsoft.com/en-ca/kb/2999226

 

And then try subsequently installing the VC Runtime for 2015 here:

 

https://www.microsoft.com/en-ca/download/details.aspx?id=48145

 

3. Otherwise if the game is failing to launch into the menu, we suggest that you first try to run in windowed mode, and disable a few settings to launch it in safe mode.

 

Instructions for changing the resolution in the launch options: Under the Games Menu in Steam, View Games Library, Right-Click We Happy Few and click "Properties". Under "Launch options", enter the following string:

-nohwdetect -ResX 1280 -ResY 720 -Windowed

 

This will disable the autodetection of your hardware, so you will need to set your graphics settings manually.

 

Please also make sure that your graphics drivers are up to date as we do not test compatibility on older versions of the graphics drivers.

 

3. If none of the above work, try seeing if you can send us a log. You'll find a log file in your user folder here. The easiest way to get to the log is by typing %localappdata%\GlimpseGame\Saved\Logs in the address bar of a Windows Explorer window, and send the file GlimpseGame.log to support@compulsiongames.com. We'll look at the data and see if we can improve the game experience for you in a future update. If there is no log, please post to this thread and we'll do our best to trouble-shoot the problem.

 

Share this post


Link to post
Share on other sites

When you say "failing to launch" is the expected outcome that it crashes or just keeps minimizing? I was able to get into the main menu and when I set the graphics to Fullscreen/1920x1080/Vsync/Ultra and clicked apply it seemed to minimize again.

Share this post


Link to post
Share on other sites

Also, after setting the game to windowed fullscreen, it does this weird thing where it is under my taskbar until I select windowed fullscreen in the options again.

*edit* actually this seems to be caused by the launch option -windowed

Share this post


Link to post
Share on other sites

Hey darthchewee;

 

I'm sorry you're having trouble with the game. When you say the application minimizes, what happens when you go back into it? Does it minimize again when you click somewhere, or does it minimize as soon as the window opens?

 

Guillaume.

Share this post


Link to post
Share on other sites

So for example, when the game is set to Windowed Fullscreen, I can get into the game just fine. But if I go into graphic options, change to Fullscreen and then click apply, it minimizes the screen and plays the audio like a scratched record for about 2 seconds. The game is still running and is in my taskbar but when I click it, it opens a black screen, plays the audio for 2 more seconds and then flashes back to my desktop or in this case chrome. At this point I have to close out of the game and then let it launch with the -windowed tag.

Share this post


Link to post
Share on other sites

Thanks @darthchewee. Two questions:

 

1. Are you video drivers up to date?

2. What exactly is your video card and operating system?

 

Thank you!

Guillaume.

Share this post


Link to post
Share on other sites

Thanks @darthchewee!

 

I'm working on this issue today. Not sure it'll make the next patch, but I think I've found the source of the problem.

 

Guillaume.

Share this post


Link to post
Share on other sites

Oh, I also run it in fullscreen, not windowed, with all checked ON except for the compass feature, resolution at 1920x1080. Aspect ratio 16:9 and Low settings for quality, which are beatuful regardless.

 

I did have trouble initially in the Wellie's district, but that resolved with your updates.

Share this post


Link to post
Share on other sites

Windows 7 Ultimate

Intel Core i3-2120 CPU @ 3.30GHz

RAM jnstalled 4 GB

64-bit OS

 

It's my housemate's machine; my laptop flatly refused.

 

Small Uncle Jack hiccup when starting a new game, but by the time he finishes saying Wellington Wells, it's fine. I let the world generate before trying to start exploring. A few pauses as I start out, but it doesn't persist.

 

I did update the NVIDIA GeForce GTX 650 graphics driver as they had an update last month. I only crashed once on the initial 6.1 day, but not yet since.

 

Thanks for a great game, and for your community support!

Share this post


Link to post
Share on other sites

Heya,

 

We Happy Few (steam version) is simply refusing to run; I hit play, and sometimes it doesn't even get to "Starting up We Happy Few..." before telling me that "GlimpseGame.exe has stopped working".

 

I can't find any logs, so this is the best I can do:

Problem signature:

Problem Event Name: APPCRASH

Application Name: GlimpseGame.exe

Application Version: 4.7.6.0

Application Timestamp: 55a6e176

Fault Module Name: KERNEL32.dll!K32GetProcessImageFileNameW

Fault Module Version: 6.0.6002.18881

Fault Module Timestamp: 51da3d16

Exception Code: c0000139

Exception Offset: 00000000000b6fc8

OS Version: 6.0.6002.2.2.0.256.6

Locale ID: 5129

Additional Information 1: fa3e

Additional Information 2: ac0507478d1c5bd693cfc4fe3987e900

Additional Information 3: fa3e

Additional Information 4: ac0507478d1c5bd693cfc4fe3987e900

 

Read our privacy statement:

 

My system specs are:

Windows Vista Business, SP2, 64-bit

Intel Core 2Quad CPU, Q9400 @ 2.66Ghz

8GB of RAM

NVIDIA GeForce GTX 750 Ti

Share this post


Link to post
Share on other sites

Hey @TheCaitularity,

 

I'm sorry you're having problems running the build. It sounds like you're dealing with an installation issue. GetProcessImageFileName( ) is the call that asks the Windows what directory the game is installed in, but it seems like the game cannot find the standard Windows DLL.

 

I've searched this on-line since it's somehow related to your installation of Microsoft Windows - I found various tidbits that talk about ensuring you have all the latest service packs installed, but it seems Microsoft itself is not super helpful with it, they just tell people to upgrade to Windows 7:

 

http://answers.microsoft.com/en-us/office/forum/office_2010-office_install/the-procedure-entry-point/7d3b9a16-f313-4f66-ac78-e5db2941966d?auth=1

 

I've also searched the Unreal Engine 4 forums which seem to indicate that Windows Vista is not supported:

https://answers.unrealengine.com/questions/176576/how-do-i-fix-a-entry-point-not-found-error-for-the.html

 

We're going to have to follow-up directly with Epic (those who make the Unreal Engine) to see if we can find a solution to it.

 

Thanks for your patience!

Guillaume.

Share this post


Link to post
Share on other sites

will getting the processor requirements down to support dual or single core processors be a priority or does the Dev team plan on utilizing 3+ cores? Also Is the core requirement for physical cores only or will hyperthreading 4 virtual cores be enough to run at "recommended" and surpass the minimum reqs?

Share this post


Link to post
Share on other sites

Hi Kalaxus!

 

Single-core machine aren't likely to be capable to run the game properly - there's just too much load between rendering and the game thread. We currently already use 3-4 cores on an average play-session, however the engine can reconfigure itself for 2 cores; I'm just not sure how well the game will run on those systems, since the hyper-thread load is likely to be pretty high on the two CPUs.

 

Guillaume.

Share this post


Link to post
Share on other sites

Hi I just purchased the game and got the code for the pre-alpha, I put it in and downloaded it. It doesn't launch! I don't know what to do I have 8GB Ram and windows 7.

Share this post


Link to post
Share on other sites

Hi @oOoVILENoOo!

 

I'm sorry you're running into issues. Have you followed the instructions at the top of this post? It is very difficult for us to diagnose the problem unless you can give us more information. Does the game crash? Does it write out a log (see above)? Have you tried the safe mode launch steps described in the FAQ?

 

Thank you!

Guillaume.

Share this post


Link to post
Share on other sites

Hi Sir, I actually fixed the launch issue, I was missing a few programs so I downloaded them from Microsoft. It launches perfectly but when I click on New Game it freezes and crashes on the "FinalizeRoads" part.

Share this post


Link to post
Share on other sites

That still counts as failing to start the game, it just fails to start a little later...

 

I just pushed a hotfix which I believe might help with your particular issue in FinalizeRoads. If the build tag in the lower right corner reads CL11915, that is the hotfixed update. See if it works and, barring that, do share your system specs as outlined in the original post so we can investigate. If the crash report window comes up when the game crashes, send a report with your forum username in the description field and we'll have a lot more information to help you.

Share this post


Link to post
Share on other sites

No offense taken, everyone on the west coast knows "bro" is a gender neutral term. People outside of the west coast just don't know better. ;)

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site you agree to the use of cookies for analytics, personalized content and ads. Privacy Policy