Jump to content
Sign in to follow this  
BlizzardVixen

Not Loading for Computers with AMD

Recommended Posts

Hello All!!! Vixen Here and I wanted to throw some info at you guys :) I have found that if you have an AMD Processor the game won't work.

When my BF logs in it says he is playing but only briefly then closes. I have seen others with this issue.

First off My BF's Computer will NOT play the game and that thing has a beastly make.

His Computer Specs are AMD FX 8Core ghz , 16gb DDR 3 Ram , Radion R9 390 8gb , 500gb solid state hard drive , Fatality Sound card , Windows 7 pro...With all the damned updates for windows. Even after uninstalling and reinstalling 3 times it hasn't worked. He got a refund on his money and now just grumpily watches me play. After going through Reddit and Forums on here . My conclusion is it has something to do with AMD Processors. My Computer has a Core i5 3.20ghz with windows 7 and Nvidia graphics card. I am hoping this helps others and Compulsion.

Share this post


Link to post
Share on other sites

Thanks for letting us know. We had AMD run some tests and it was working fine but we'll still investigate your suggestion.

Share this post


Link to post
Share on other sites

@BlizzardVixen We've pushed an update this afternoon that seems like it might address what you're describing. Certain users were unable to start the game due to their Windows installation missing some essential files. We now push these files alongside the game just to be safe.

 

On the bright side, if this fixes it, then the problem isn't the AMD hardware. ;)

Share this post


Link to post
Share on other sites
On 7/28/2016 at 5:37 PM, BlizzardVixen said:

Hello All!!! Vixen Here and I wanted to throw some info at you guys :) I have found that if you have an AMD Processor the game won't work.

When my BF logs in it says he is playing but only briefly then closes. I have seen others with this issue.

First off My BF's Computer will NOT play the game and that thing has a beastly make.

His Computer Specs are AMD FX 8Core ghz , 16gb DDR 3 Ram , Radion R9 390 8gb , 500gb solid state hard drive , Fatality Sound card , Windows 7 pro...With all the damned updates for windows. Even after uninstalling and reinstalling 3 times it hasn't worked. He got a refund on his money, watches under 2000 and now just grumpily watches me play. After going through Reddit and Forums on here . My conclusion is it has something to do with AMD Processors. My Computer has a Core i5 3.20ghz with windows 7 and Nvidia graphics card. I am hoping this helps others and Compulsion.

thanks for sharing!

Edited by dh905763

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site you agree to the use of cookies for analytics, personalized content and ads. Privacy Policy